# News: LINE SDK v4.x end-of-life on December 12th, 2019

LINE SDK v4.x end-of-life on December 12th, 2019

December 12th, 2019 marks the end-of-life date for LINE SDK v4.0 for Android and LINE SDK v4.1 for iOS (from hereon collectively called LINE SDK v4.x). On that date, we'll remove from this site the following things:

# Why we're doing this

To ensure a consistent, secure, up-to-date experience for LINE users, our partners' apps and services should use the latest version of our technology. We already marked LINE SDK v4.x as deprecated some time ago, but continued to offer documentation and download links as a courtesy to partners who couldn't upgrade on short notice. Now we're taking the next logical step: declaring LINE SDK v4.x end-of-life and removing all references from our site.

# Upgrading to a new SDK version

What you need to do to upgrade depends on what version you're currently using.

From To Notes
LINE SDK v4.x for iOS Objective-C LINE SDK v5.2 for iOS Swift The old and new versions use different programming languages, which makes migrating a big task. We hope the migration instructions in Upgrading the SDK will make it easier.
LINE SDK v4.x for Android LINE SDK v5.1 for Android There are minor differences between the old and new version, particularly with relation to how login works. The page Integrating LINE Login with your Android app explains how to integrate the latest version.
LINE SDK v3.x for iOS Objective-C LINE SDK v5.2 for iOS Swift There are major differences between the old and new version, meaning you'll have to redo your integration from scratch. See Integrating LINE Login with your iOS app for instructions.
LINE SDK v3.x for Android LINE SDK v5.1 for Android There are major differences between the old and new version, meaning you'll have to redo your integration from scratch. See Integrating LINE Login with your Android app for instructions.